Technical Requirements

Please observe the following requirements to ensure a successful installation of the Content Engagement Plugin:

  • Existing Mapp integration with pixel version 3.2.1 or 4.3.4 or higher.
  • When using Smart Pixel, the extension "wtSmart.extension.content_engagement" is available by default (see Smart Pixel Integration).

  • For a correct measurement in Mozilla Firefox, you need at least the pixel version 3.2.5.
  • Integration of the JavaScript file "pixel-contentengagement.min.js."
  • The necessary event parameters, which are preconfigured in Mapp Q3, must be created (see Creating Event Parameters).

Download

To integrate the Content Engagement plugin, you need the corresponding JS file (pixel-contentengagement.min.js). You can download it here.

Browser Support

The Content Engagement Plugin uses the querySelector method to search for the elements to be measured. The following browsers support this method:

  • Internet Explorer from version 8
  • Microsoft Edge
  • Firefox from version 3.5
  • Google Chrome
  • Safari from version 3
  • Opera from version 10